Announcement

Collapse
No announcement yet.

Level Up System Works, but Display Blank

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Level Up System Works, but Display Blank

    Hi Folks,

    I will post this just in case it happens to you. I had to take the Montana up to repair faculty (someone hit my cap while sitting in storage). I had to pick it up in early morning, to be back home in time for work. I went to hook up the truck, and powered on the Level Up System, and there was no display. I remember which buttons to press to put it in manual mode, so I went head and hooked up and dropped off the Montana.

    When I got the Montana back home a month later, the display was still out (and out of warranty), so I decided to unplug the wire harness from the display and re plug it in too kind of reboot it. Display has been working fine ever since.


    2015 Montana 3611RL
    2001 Ford F350 XLT Crew Cab 4WD SRW 7.3L Diesel

    God Bless,
    John Walker
    Indian Land, SC
    Blog http://montana3611rl.blogspot.com/
    Two things Eternal... The Word of God (The Bible) and the Souls of Men.

  • #2
    Thats some very good info, thanks!!!!

    Comment


    • #3
      Good info thanks John!
      Love playing in the "Father's" yard, enjoying His Creations!

      Comment


      • #4
        A poke in the eye, always works! Good tip to remember.
        Scott Luciano aka Montana Rover
        My better half is Pati aka Sunshine

        Lakeland, Florida

        1-Savior + 3-Nails= 4GIVEN


        2012 - Ram 3500 4x4 Longhorn Dually, 4:10 Max Tow PKG, Sun Roof, 440 HP 925 TQ, H&S Maxx Street Programmer

        2014 - Montana 3402RL, Paramount & Full Time Living PKG, Goodyear G614 Tires, Amish Made Furniture

        Comment


        • #5
          I did that with mine too, and it worked for a little while. I ended up calling Lippert(I was out of warranty also) and they sent me a new pad which lasted about a year and went out too. I called again and they sent me another one.

          The paperwork that came with my new ones said the cost of the pad was $12.95. I guess that's why they sent me 2 new ones for free.
          Tom & Sharon
          2010 Montana 3150RL, gone but not forgotten
          2016 RAM 3500 DRW with 373 rear
          2016 Landmark Orlando 5th wheel

          Comment


          • 7.3Ford
            7.3Ford commented
            Editing a comment
            Good to know Tom.

        • #6
          Unplugging and plugging back in will fix a variety of problems...I have had to do it a couple of times for different things
          2014 Cedar Creek Silverback
          2010 Dodge Ram Laramie 3500 dually
          :cool:

          Comment


          • #7
            I had a blank display and did the unplug trick. Worked for a while but quit again. Worked with Lippert CS and check voltages on the wires. The display was bad and I replaced with new. The cost was a little over $200. My extended warranty covered it. 2014 3100RL. FYI: Pressing the On button, up arrow once and then Enter, places the system in Manual mode.
            Bob
            Midwest Texas Alabama
            Full Timing in a 2014 3100RL
            3500 DuraMax DRW

            Comment

            Working...
            X